Email Disruption

Incident Report for ProDeal360

Resolved

Maintenance of email notifications has concluded.
Posted Feb 11, 2020 - 20:35 EST

Identified

ProDeal email notifications are currently not being sent to users while our engineering team performs maintenance on the application.
Posted Feb 11, 2020 - 10:09 EST
This incident affected: Prod (Core Application).